shrug-l: Append Tool Not Working Correctly In Model Builder

Tripp Corbin tcorbin at keckwood.com
Thu Jan 28 17:14:43 EST 2010


Jim,

Sounds like a very interesting problem. The way the environmental
settings are suppose to work is tool settings override Application
Settings. Models can be a little different. If a model is run as a tool,
the tool setting are suppose to override the application settings and
the model settings are suppose to override the tool settings.  If the
model is run in model builder the tool settings are ignored and the
model settings are used. The model settings are then overridden by the
Model Process settings. These are basically the properties of each tool
used in the model itself. 

 

So it sound like you might have possible conflicting settings at the
model process level that are resolved by the tool level when you run the
model as a tool and not in model builder.  Does that make sense? 

 

Tripp Corbin, MCP, CFM, GISP
Vice President, GIS/IT
ESRI Authorized Instructor
Keck & Wood, Inc. <http://www.keckwood.com/> 
(678) 417-4013
(678) 417-8785 fax



 

From: shrug-l-bounces at lists.dep.state.fl.us
[mailto:shrug-l-bounces at lists.dep.state.fl.us] On Behalf Of Thomas, Jim
Sent: Thursday, January 28, 2010 4:51 PM
To: shrug-l at lists.dep.state.fl.us
Subject: shrug-l: Append Tool Not Working Correctly In Model Builder

 

Hi All,

 

Has anyone experienced the following problem, if so, can you offer a
solution or explanation?

 

I'm running an Append process in ArcGIS ModelBuilder.  The inputs are
all using the %workspace% variable and the workspace path is set at the
model level (model properties...).  If I run the process from inside the
model, it appends the records, but the attribute values are empty.  If I
flag each input as a parameter and run the model from the toolbox
(double click model), the inputs are not found until I set the workspace
path at the tool level (Environment...).  When I run it that way, both
records and values are added to the output correctly.    BTW - This only
happens with the Append tool... the other tools work properly in either
scenario.  We've been able to duplicate this problem on other machines,
so it appears to be an ArcGIS issue.

 

Bottom line - I want to be able to run the model without having to set
the environment workspace each time, and I also want to be able to run
it from inside ModelBuilder.   Maybe I'm misunderstanding the
Environment Settings hierarchy, but why does it only affect the Append
tool?

 

Can anyone offer an explanation?

 

Thanks.

 

________________________________

Jim Thomas, GISP | GIS Analyst | Golder Associates Inc.            
9428 Baymeadows Road, Suite 400, Jacksonville, Florida, USA 32256      
T: +1 (904) 363-3430 | F: +1 (904) 363-3445 | E: jim_thomas at golder.com
<mailto:jim_thomas at golder.com>  | www.golder.com
<http://www.golder.com/>           

Work Safe, Home Safe  

This email transmission is confidential and may contain proprietary
information for the exclusive use of the intended recipient. Any use,
distribution or copying of this transmission, other than by the intended
recipient, is strictly prohibited. If you are not the intended
recipient, please notify the sender and delete all copies. Electronic
media is susceptible to unauthorized modification, deterioration, and
incompatibility. Accordingly, the electronic media version of any work
product may not be relied upon.    

Please consider the environment before printing this email.     

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.dep.state.fl.us/pipermail/shrug-l/attachments/20100128/18972372/attachment.html


More information about the SHRUG-L mailing list